Incidents

SMS notifications are not being delivered

MAJORaffectedSMSlasted1d 20h 25min 34s

Resolved

resolved
Mar 18 16:44:46 (UTC)

Example update

investigating
Mar 18 16:44:18 (UTC)
Powered by Checkly